const regex = /^(!?){0}([+]){1}([998]){3}\s([7-9]){1}([0-9]){1}\s([0-9]){3}\s([0-9]){2}\s([0-9]){2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(!?){0}([+]){1}([998]){3}\\s([7-9]){1}([0-9]){1}\\s([0-9]){3}\\s([0-9]){2}\\s([0-9]){2}$', 'gm')
const str = `+998 99 477 55 55
998 33 665 55 55
+997 66 123 12 12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}