re = /^http:\/\/pre.m2.(?:lacaixa|caixabank).es:80\/HBK\/WAP\/INT(?:\/UPLOAD)*\/TLO.*/m
str = 'http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/CABRO/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/UPLOAD/UPLOAD/UPLOAD/TLO/jsp/eloautp000001.jsp;WebLogicSession=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-1153479860!NONE?URI=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-11486721908313
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end