import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http://pre.m2.(?:lacaixa|caixabank).es:80/HBK/WAP/INT(?:/UPLOAD)*/TLO.*";
final String string = "http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/CABRO/TLO\n"
+ "http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/TLO\n"
+ "http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/TLO\n"
+ "http://pre.m2.caixabank.es:80/HBK/WAP/INT/TLO\n"
+ "http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/UPLOAD/UPLOAD/UPLOAD/TLO/jsp/eloautp000001.jsp;WebLogicSession=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-1153479860!NONE?URI=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-11486721908313\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}