using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http://pre.m2.(?:lacaixa|caixabank).es:80/HBK/WAP/INT(?:/UPLOAD)*/TLO.*";
string input = @"http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/CABRO/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/UPLOAD/UPLOAD/UPLOAD/TLO/jsp/eloautp000001.jsp;WebLogicSession=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-1153479860!NONE?URI=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-11486721908313
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}