const regex = new RegExp('^http://pre.m2.(?:lacaixa|caixabank).es:80/HBK/WAP/INT(?:/UPLOAD)*/TLO.*', 'gm')
const str = `http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/CABRO/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/TLO
http://pre.m2.caixabank.es:80/HBK/WAP/INT/UPLOAD/UPLOAD/UPLOAD/UPLOAD/UPLOAD/TLO/jsp/eloautp000001.jsp;WebLogicSession=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-1153479860!NONE?URI=4H9kYdSZbZXQ4vvK4NkKrXlDmbcXhg1w57ch6GNF582TphxQPHc5!-11486721908313
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}