# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([\(\[])?([(?:IWantOut|WeWantOut)\w\.])+?([\)\]])?(\W*\s*-*—*(>)+)\s*([\(\[])?[\w\/\\,\s]+([\)\]])?)"
test_str = ("us----> canada\n"
"[IWantOut] 25F Japan-> USA/UK\n"
"[EU] -> [AUS] Question about document translation\n"
"(22F) -> Germany;\n"
"Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?\n"
"We want out U.S.->France;\n"
"USA -> South America")
matches = re.finditer(regex, test_str, re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.