using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([\(\[])?([(?:IWantOut|WeWantOut)\w\.])+?([\)\]])?(\W*\s*-*—*(>)+)\s*([\(\[])?[\w\/\\,\s]+([\)\]])?)";
string input = @"us----> canada
[IWantOut] 25F Japan-> USA/UK
[EU] -> [AUS] Question about document translation
(22F) -> Germany;
Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?
We want out U.S.->France;
USA -> South America";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}