import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([\\(\\[])?([(?:IWantOut|WeWantOut)\\w\\.])+?([\\)\\]])?(\\W*\\s*-*—*(>)+)\\s*([\\(\\[])?[\\w\\/\\\\,\\s]+([\\)\\]])?)";
final String string = "us----> canada\n"
+ "[IWantOut] 25F Japan-> USA/UK\n"
+ "[EU] -> [AUS] Question about document translation\n"
+ "(22F) -> Germany;\n"
+ "Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?\n"
+ "We want out U.S.->France;\n"
+ "USA -> South America";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}