#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(([\(\[])?([(?:IWantOut|WeWantOut)\w\.])+?([\)\]])?(\W*\s*-*—*(>)+)\s*([\(\[])?[\w\/\\,\s]+([\)\]])?)"
Local $sString = "us----> canada" & @CRLF & _
"[IWantOut] 25F Japan-> USA/UK" & @CRLF & _
"[EU] -> [AUS] Question about document translation" & @CRLF & _
"(22F) -> Germany;" & @CRLF & _
"Looking for someone with experience moving out of USA to --->(Japan, Korea, Western Europe, or Australia)? AKA, a mentor?" & @CRLF & _
"We want out U.S.->France;" & @CRLF & _
"USA -> South America"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")