// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d+) (?:(?:<(CARRE|RECTANGLE|OVALE|LIGNE)> (\d+) (\d+) (\d+) (\d+) </(?:CARRE|RECTANGLE|OVALE|LIGNE)>)|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>)$").unwrap();
let string = "1111 <CARRE> 123 321 111 222 </CARRE>
2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>
3333 <CERCLE> 345 543 555 </CERCLE>
4444 <OVALE> 456 654 666 777 </OVALE>
5555 <LIGNE> 567 765 888 999 </LIGNE>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}