$re = '/^(\d+) (?:(?:<(CARRE|RECTANGLE|OVALE|LIGNE)> (\d+) (\d+) (\d+) (\d+) </(?:CARRE|RECTANGLE|OVALE|LIGNE)>)|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>)$/';
$str = '1111 <CARRE> 123 321 111 222 </CARRE>
2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>
3333 <CERCLE> 345 543 555 </CERCLE>
4444 <OVALE> 456 654 666 777 </OVALE>
5555 <LIGNE> 567 765 888 999 </LIGNE>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);