using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+) (?:(?:<(CARRE|RECTANGLE|OVALE|LIGNE)> (\d+) (\d+) (\d+) (\d+) </(?:CARRE|RECTANGLE|OVALE|LIGNE)>)|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>)$";
string input = @"1111 <CARRE> 123 321 111 222 </CARRE>
2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>
3333 <CERCLE> 345 543 555 </CERCLE>
4444 <OVALE> 456 654 666 777 </OVALE>
5555 <LIGNE> 567 765 888 999 </LIGNE>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}