import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+) (?:(?:<(CARRE|RECTANGLE|OVALE|LIGNE)> (\\d+) (\\d+) (\\d+) (\\d+) </(?:CARRE|RECTANGLE|OVALE|LIGNE)>)|<(CERCLE)> (\\d+) (\\d+) (\\d+) </CERCLE>)$";
final String string = "1111 <CARRE> 123 321 111 222 </CARRE>\n"
+ "2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>\n"
+ "3333 <CERCLE> 345 543 555 </CERCLE>\n"
+ "4444 <OVALE> 456 654 666 777 </OVALE>\n"
+ "5555 <LIGNE> 567 765 888 999 </LIGNE>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}