// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?P<severity>DEBUG|TRACE|FATAL|[Ii](?:nfo|NFO)|[Ww](?:arn(?:ing)?|ARN(?:ING)?)|[Ee](?:rror|RROR|xception|XCEPTION))\b").unwrap();
let string = "{\"exception\":\"\",\"severity\":\"Warn \",\"SRC\":\"CardholderProcessorService.DAL.DataFunctions.UpdateCardNotValid \",\"xFor\":\"\",\"w\":\"\",\"PID\":\"3848 \",\"message\":\"Card was not issued (CardholderId=3946418 DebitCardId=4366182403580205). Please check card application. Reason: {City: Invalid behavior for CPS_City: City does not match regex: ^[a-zA-Z\\\\\\\\.][a-zA-Z\\\\\\\\. ]*[a-zA-Z\\\\\\\\.]$.} Details: City has to be letters only, no numbers or dashes or commas or any other characters. Spaces should only be 1 space long\",\"TID\":\"121 \",\"Url\":\"\",\"SId\":\"\",\"VSID\":\"5 \",\"site\":\"HRZ\",\"REF\":\"\",\"TKID\":\"\",\"CSys\":\"\",\"response\":\"\",\"AHID\":\"\",\"timestamp\":\"2019-09-04 00:20:31.1409 \",\"CID\":\"311aca82-7056-49a1-93b1-0d0da802f976 \",\"CHID\":\"\"}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}