#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?P<severity>DEBUG|TRACE|FATAL|[Ii](?:nfo|NFO)|[Ww](?:arn(?:ing)?|ARN(?:ING)?)|[Ee](?:rror|RROR|xception|XCEPTION))\b"
Local $sString = "{"exception":"","severity":"Warn ","SRC":"CardholderProcessorService.DAL.DataFunctions.UpdateCardNotValid ","xFor":"","w":"","PID":"3848 ","message":"Card was not issued (CardholderId=3946418 DebitCardId=4366182403580205). Please check card application. Reason: {City: Invalid behavior for CPS_City: City does not match regex: ^[a-zA-Z\\\\.][a-zA-Z\\\\. ]*[a-zA-Z\\\\.]$.} Details: City has to be letters only, no numbers or dashes or commas or any other characters. Spaces should only be 1 space long","TID":"121 ","Url":"","SId":"","VSID":"5 ","site":"HRZ","REF":"","TKID":"","CSys":"","response":"","AHID":"","timestamp":"2019-09-04 00:20:31.1409 ","CID":"311aca82-7056-49a1-93b1-0d0da802f976 ","CHID":""}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")