import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?P<severity>DEBUG|TRACE|FATAL|[Ii](?:nfo|NFO)|[Ww](?:arn(?:ing)?|ARN(?:ING)?)|[Ee](?:rror|RROR|xception|XCEPTION))\\b";
final String string = "{\"exception\":\"\",\"severity\":\"Warn \",\"SRC\":\"CardholderProcessorService.DAL.DataFunctions.UpdateCardNotValid \",\"xFor\":\"\",\"w\":\"\",\"PID\":\"3848 \",\"message\":\"Card was not issued (CardholderId=3946418 DebitCardId=4366182403580205). Please check card application. Reason: {City: Invalid behavior for CPS_City: City does not match regex: ^[a-zA-Z\\\\\\\\.][a-zA-Z\\\\\\\\. ]*[a-zA-Z\\\\\\\\.]$.} Details: City has to be letters only, no numbers or dashes or commas or any other characters. Spaces should only be 1 space long\",\"TID\":\"121 \",\"Url\":\"\",\"SId\":\"\",\"VSID\":\"5 \",\"site\":\"HRZ\",\"REF\":\"\",\"TKID\":\"\",\"CSys\":\"\",\"response\":\"\",\"AHID\":\"\",\"timestamp\":\"2019-09-04 00:20:31.1409 \",\"CID\":\"311aca82-7056-49a1-93b1-0d0da802f976 \",\"CHID\":\"\"}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}