# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?P<severity>DEBUG|TRACE|FATAL|[Ii](?:nfo|NFO)|[Ww](?:arn(?:ing)?|ARN(?:ING)?)|[Ee](?:rror|RROR|xception|XCEPTION))\b"
test_str = ("{\"exception\":\"\",\"severity\":\"Warn \",\"SRC\":\"CardholderProcessorService.DAL.DataFunctions.UpdateCardNotValid \",\"xFor\":\"\",\"w\":\"\",\"PID\":\"3848 \",\"message\":\"Card was not issued (CardholderId=3946418 DebitCardId=4366182403580205). Please check card application. Reason: {City: Invalid behavior for CPS_City: City does not match regex: ^[a-zA-Z\\\\\\\\.][a-zA-Z\\\\\\\\. ]*[a-zA-Z\\\\\\\\.]$.} Details: City has to be letters only, no numbers or dashes or commas or any other characters. Spaces should only be 1 space long\",\"TID\":\"121 \",\"Url\":\"\",\"SId\":\"\",\"VSID\":\"5 \",\"site\":\"HRZ\",\"REF\":\"\",\"TKID\":\"\",\"CSys\":\"\",\"response\":\"\",\"AHID\":\"\",\"timestamp\":\"2019-09-04 00:20:31.1409 \",\"CID\":\"311aca82-7056-49a1-93b1-0d0da802f976 \",\"CHID\":\"\"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.