import Foundation
let pattern = ##"^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
{ # comment 1
"hello": "Wor#d", "Bye": "\"M#rk\"",# comment" 2
"quote": "\"th#t's\" what she said", # comment 3
"list": [1, 1, "#", "\"", 5, 8] # comment 4 with "quotes"
}
# comment 5
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)