re = /^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$/mi
str = '{ # comment 1
"hello": "Wor#d", "Bye": "\\"M#rk\\"",# comment" 2
"quote": "\\"th#t\'s\\" what she said", # comment 3
"list": [1, 1, "#", "\\"", 5, 8] # comment 4 with "quotes"
}
# comment 5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end