import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\"#]*\".*\"[^\"#]*|[^\"#]*)(#.*)?$";
final String string = "{ # comment 1\n"
+ " \"hello\": \"Wor#d\", \"Bye\": \"\\\"M#rk\\\"\",# comment\" 2\n"
+ " \"quote\": \"\\\"th#t's\\\" what she said\", # comment 3\n"
+ " \"list\": [1, 1, \"#\", \"\\\"\", 5, 8] # comment 4 with \"quotes\"\n"
+ "}\n"
+ "# comment 5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}