const regex = new RegExp('^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$', 'gmi')
const str = `{ # comment 1
"hello": "Wor#d", "Bye": "\\"M#rk\\"",# comment" 2
"quote": "\\"th#t's\\" what she said", # comment 3
"list": [1, 1, "#", "\\"", 5, 8] # comment 4 with "quotes"
}
# comment 5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}