re = /^[Oo]?[BbPp]?.*\s*(REP[Ll]*\.?\s*BY|[Oo]+[BbPp]+.*\s*REP)/
str = 'OBSREPL.BY'
# Print the match result
str.match(re) do |match|
puts match.to_s
end