package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[Oo]?[BbPp]?.*\s*(REP[Ll]*\.?\s*BY|[Oo]+[BbPp]+.*\s*REP)`)
var str = `OBSREPL.BY`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}