using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[Oo]?[BbPp]?.*\s*(REP[Ll]*\.?\s*BY|[Oo]+[BbPp]+.*\s*REP)";
string input = @"OBSREPL.BY";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}