#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[Oo]?[BbPp]?.*\s*(REP[Ll]*\.?\s*BY|[Oo]+[BbPp]+.*\s*REP)"
Local $sString = "OBSREPL.BY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")