$re = '~Garde-(.*?)(svg#Uni)(.*?)\'~';
$str = '@font-face { font-family: \'UniRegular\'; src: url(\'../../assets/type/UniGarde-Book.svg#UniGarde-Book\') format(\'svg\'); }';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);