#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Garde-(.*?)(svg#Uni)(.*?)'"
Local $sString = "@font-face { font-family: 'UniRegular'; src: url('../../assets/type/UniGarde-Book.svg#UniGarde-Book') format('svg'); }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")