const regex = new RegExp('Garde-(.*?)(svg#Uni)(.*?)\\'', '')
const str = `@font-face { font-family: 'UniRegular'; src: url('../../assets/type/UniGarde-Book.svg#UniGarde-Book') format('svg'); }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}