using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Garde-(.*?)(svg#Uni)(.*?)'";
string input = @"@font-face { font-family: 'UniRegular'; src: url('../../assets/type/UniGarde-Book.svg#UniGarde-Book') format('svg'); }";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}