// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^A-Za-z]|\b)+DR([^A-Za-z]|\b)+").unwrap();
let string = "DR. This is my test string I want to match dr occurences of the case-sensitive word DR. I want all matches where DR is by itself and not part of a word such as DRIFT. I want to find it in the start of and end of a string. DR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}