re = /([^A-Za-z]|\b)+DR([^A-Za-z]|\b)+/
str = 'DR. This is my test string I want to match dr occurences of the case-sensitive word DR. I want all matches where DR is by itself and not part of a word such as DRIFT. I want to find it in the start of and end of a string. DR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end