const regex = /([^A-Za-z]|\b)+DR([^A-Za-z]|\b)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^A-Za-z]|\\b)+DR([^A-Za-z]|\\b)+', 'g')
const str = `DR. This is my test string I want to match dr occurences of the case-sensitive word DR. I want all matches where DR is by itself and not part of a word such as DRIFT. I want to find it in the start of and end of a string. DR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}