re = /\n/m
str = 'dgxxxxbfbb sjadlasgdlgasli
shadcksavdlcvlas
ashccjhlasvhlcvlasdhc
skjbckjsajc
hjvjcjjhchgcjh
hgcjhcjc hjgchj
ghjxgxng'
subst = '\\b'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result