# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n/\b/gm;t' <<< "dgxxxxbfbb sjadlasgdlgasli
shadcksavdlcvlas
ashccjhlasvhlcvlasdhc
skjbckjsajc
hjvjcjjhchgcjh
hgcjhcjc hjgchj
ghjxgxng"