import Foundation
let pattern = ##"""
^((ftp|http)s?:\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/asdadsasd/asdsad
https://adasd.com/adasdad/adaa
asdasdas/asdasdasd.ads?Asdasda
asdasdas/asdasdasd.ads
adasdd.rgg/asdasdasdas?dasdasd#asdads.as
http://rrsda.COM/cCCC
asdasdsda.ccc
asdsad/asdsad
/asdasdasdasdasd/asdasd/
../asdasdsad/asdasd/asdsad
./asdasdsad.asdasd
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)