#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((ftp|http)s?:\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?$" & @CRLF & _
""
Local $sString = "/asdadsasd/asdsad" & @CRLF & _
"https://adasd.com/adasdad/adaa" & @CRLF & _
"asdasdas/asdasdasd.ads?Asdasda" & @CRLF & _
"asdasdas/asdasdasd.ads" & @CRLF & _
"adasdd.rgg/asdasdasdas?dasdasd#asdads.as" & @CRLF & _
"http://rrsda.COM/cCCC" & @CRLF & _
"asdasdsda.ccc" & @CRLF & _
"" & @CRLF & _
"asdsad/asdsad" & @CRLF & _
"/asdasdasdasdasd/asdasd/" & @CRLF & _
"" & @CRLF & _
"../asdasdsad/asdasd/asdsad" & @CRLF & _
"./asdasdsad.asdasd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")