using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((ftp|http)s?:\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?$
";
string input = @"/asdadsasd/asdsad
https://adasd.com/adasdad/adaa
asdasdas/asdasdasd.ads?Asdasda
asdasdas/asdasdasd.ads
adasdd.rgg/asdasdasdas?dasdasd#asdads.as
http://rrsda.COM/cCCC
asdasdsda.ccc
asdsad/asdsad
/asdasdasdasdasd/asdasd/
../asdasdsad/asdasd/asdsad
./asdasdsad.asdasd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}