$re = '/^((ftp|http)s?:\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?$
/m';
$str = '/asdadsasd/asdsad
https://adasd.com/adasdad/adaa
asdasdas/asdasdasd.ads?Asdasda
asdasdas/asdasdasd.ads
adasdd.rgg/asdasdasdas?dasdasd#asdads.as
http://rrsda.COM/cCCC
asdasdsda.ccc
asdsad/asdsad
/asdasdasdasdasd/asdasd/
../asdasdsad/asdasd/asdsad
./asdasdsad.asdasd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);