const regex = /<\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\?[^?])*))\?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\\?[^?])*))\\?>', 'g')
const str = `<?php
\$lang=JFactory::getLanguage()->getLang();
\$lang=substr(\$lang,0,2).>;if (\$l<<<<>>>>ang=='uk')
\$lang='ua';
echo JRoute::_("index.php?option=zzp?com_sim&layout=pedaski&limit=1&limitstart=1&view=pedagogie&lang=courchevel-\$lang");?> <>
<?php zdezf .
ssasa dns
dzdn
echo JText::_("PEDAEQUIP");?></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}