#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\?[^?])*))\?>"
Local $sString = "<?php " & @CRLF & _
"$lang=JFactory::getLanguage()->getLang(); " & @CRLF & _
" $lang=substr($lang,0,2).>;if ($l<<<<>>>>ang=='uk')" & @CRLF & _
" $lang='ua';" & @CRLF & _
" echo JRoute::_("index.php?option=zzp?com_sim&layout=pedaski&limit=1&limitstart=1&view=pedagogie&lang=courchevel-$lang");?> <>" & @CRLF & _
"" & @CRLF & _
" <?php zdezf . " & @CRLF & _
"ssasa dns" & @CRLF & _
"dzdn" & @CRLF & _
"" & @CRLF & _
" echo JText::_("PEDAEQUIP");?></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")