using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\?[^?])*))\?>";
string input = @"<?php
$lang=JFactory::getLanguage()->getLang();
$lang=substr($lang,0,2).>;if ($l<<<<>>>>ang=='uk')
$lang='ua';
echo JRoute::_(""index.php?option=zzp?com_sim&layout=pedaski&limit=1&limitstart=1&view=pedagogie&lang=courchevel-$lang"");?> <>
<?php zdezf .
ssasa dns
dzdn
echo JText::_(""PEDAEQUIP"");?></a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}