import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\\?[^?])*))\\?>";
final String string = "<?php \n"
+ "$lang=JFactory::getLanguage()->getLang(); \n"
+ " $lang=substr($lang,0,2).>;if ($l<<<<>>>>ang=='uk')\n"
+ " $lang='ua';\n"
+ " echo JRoute::_(\"index.php?option=zzp?com_sim&layout=pedaski&limit=1&limitstart=1&view=pedagogie&lang=courchevel-$lang\");?> <>\n\n"
+ " <?php zdezf . \n"
+ "ssasa dns\n"
+ "dzdn\n\n"
+ " echo JText::_(\"PEDAEQUIP\");?></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}