re = /^([^;,\n]*)(;.*(\1)(,.*|;)?|;;)$/m
str = '/foo;/foo,/bar,/test;
/foo;/bar,/foo,/test;
/foo;/bar,/test,/foo;
/foo;/bar,/baz,/test;
/foo;;/foo,/bar,/test
/foo;;/bar,/foo,/test
/foo;;/bar,/test,/foo
/foo;;/bar,/baz,/test
/foo;;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end