$re = '/^([^;,\n]*)(;.*(\1)(,.*|;)?|;;)$/m';
$str = '/foo;/foo,/bar,/test;
/foo;/bar,/foo,/test;
/foo;/bar,/test,/foo;
/foo;/bar,/baz,/test;
/foo;;/foo,/bar,/test
/foo;;/bar,/foo,/test
/foo;;/bar,/test,/foo
/foo;;/bar,/baz,/test
/foo;;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);