#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^;,\n]*)(;.*(\1)(,.*|;)?|;;)$"
Local $sString = "/foo;/foo,/bar,/test;" & @CRLF & _
"/foo;/bar,/foo,/test;" & @CRLF & _
"/foo;/bar,/test,/foo;" & @CRLF & _
"/foo;/bar,/baz,/test;" & @CRLF & _
"/foo;;/foo,/bar,/test" & @CRLF & _
"/foo;;/bar,/foo,/test" & @CRLF & _
"/foo;;/bar,/test,/foo" & @CRLF & _
"/foo;;/bar,/baz,/test" & @CRLF & _
"/foo;;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")