import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^;,\\n]*)(;.*(\\1)(,.*|;)?|;;)$";
final String string = "/foo;/foo,/bar,/test;\n"
+ "/foo;/bar,/foo,/test;\n"
+ "/foo;/bar,/test,/foo;\n"
+ "/foo;/bar,/baz,/test;\n"
+ "/foo;;/foo,/bar,/test\n"
+ "/foo;;/bar,/foo,/test\n"
+ "/foo;;/bar,/test,/foo\n"
+ "/foo;;/bar,/baz,/test\n"
+ "/foo;;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}