re = /^[1-9]\d{5}[1-9]\d{3}((0[1-9])|(1[0-2]))(((0[1-9])|3[0-1])|(([1|2]\d)|3[0-1]))\d{3}([0-9]|X)$/
str = '342501199002210613'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end