using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]\d{5}[1-9]\d{3}((0[1-9])|(1[0-2]))(((0[1-9])|3[0-1])|(([1|2]\d)|3[0-1]))\d{3}([0-9]|X)$";
string input = @"342501199002210613";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}