package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1-9]\d{5}[1-9]\d{3}((0[1-9])|(1[0-2]))(((0[1-9])|3[0-1])|(([1|2]\d)|3[0-1]))\d{3}([0-9]|X)$`)
var str = `342501199002210613`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}