import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d{5}[1-9]\\d{3}((0[1-9])|(1[0-2]))(((0[1-9])|3[0-1])|(([1|2]\\d)|3[0-1]))\\d{3}([0-9]|X)$";
final String string = "342501199002210613";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}